Browser Not Supported

Countfire takes advantage of some new and powerful features that only Google Chrome has, so you'll need to open Countfire in a recent version of Google Chrome for it to work.

If you don't already have it installed, you can download Google Chrome here.